All times are UTC + 10 hours [ DST ]




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Fd sputtering, hesitating on 1/4 throttle
PostPosted: Thu Nov 23, 2017 4:25 pm 
Offline
Registered Rotor User

Joined: Thu Nov 23, 2017 2:39 pm
Posts: 2
Hi everyone im new to this forum and to the rotary world. Im having issues with my stock fd. It would be great if you could help.

So when i bought my car a month ago the boost gauge was not working: sitting at the bottom -20 and it was/still running rich and fluctuating at idle but drives fine on acceleration.

I drove it yesterday and it was running as mentioned above until today. As soon as i drove out my driveway it sputters and hesitates at 1/4 throttle. The boost gauge also started working but was still sitting at the bottom and did not move passed 0. The car does NOT stall or shut off.

I have replaced the vacuum hoses to silicone hoses last week.
Could this be a TPS or MAP sensor issue?

I tried uploading a vid but would not work


Top
 Profile E-mail  
 
 Post subject: Re: Fd sputtering, hesitating on 1/4 throttle
PostPosted: Fri Nov 24, 2017 2:08 am 
Offline
Rotary?... What The?

Joined: Wed May 18, 2016 10:26 pm
Posts: 33
Location: S Devon - ENGLAND
I have just had a very similar problem with my FC TII, kept dropping in/out of boost, checked all the obvious until a rotary Guru friend :bow: told me to check the Electric OMP connections/clean them........low & behold problem solved.

_________________
Currently Own:- S3 RX7 FB & RX7 FC TII Vert
Previously Owned:- 2 x NSU Ro 80s.....2 x S2 FBs.....DKW W 2000....Suzuki RE5....Norton Commander


Top
 Profile E-mail  
 
 Post subject: Re: Fd sputtering, hesitating on 1/4 throttle
PostPosted: Fri Nov 24, 2017 9:55 am 
Offline
Administrator
User avatar

Joined: Tue Jul 09, 2002 7:09 am
Posts: 14818
Location: Melbourne
What version FD?

The solenoid box is known to go. I recall Mazda upgraded in the solenoid box in series 8 models (Version V & VI) but even though they still require replacement periodically. Solenoid and vacuum line issues can be very tricky to diagnose and produce all sorts of weird behaviour.

_________________
My Build Log
WTB series 3 RX-7 shifter boot in off black/grey


Top
 Profile  
 
 Post subject: Re: Fd sputtering, hesitating on 1/4 throttle
PostPosted: Fri Nov 24, 2017 11:03 am 
Offline
Registered Rotor User

Joined: Thu Nov 23, 2017 2:39 pm
Posts: 2
Its a '99 Type Rs version 5

The vac hoses were very brittle around the solenoid box.
Is there anyway to test it?

I've also had a quick look around the omp, seems to be some oil around the hoses. Ill check it out properly when i get home from work


Top
 Profile E-mail  
 
 Post subject: Re: Fd sputtering, hesitating on 1/4 throttle
PostPosted: Fri Nov 24, 2017 9:58 pm 
Offline
Rotor Junkie

Joined: Sun Mar 05, 2006 6:45 pm
Posts: 4344
Location: Sydney
There is a fault finding post in tech section at fdrx7.com seems to be mostly Australian guys there, not sure why they needed a separate forum but there is a lot of fd specific tech there.

Could be an electrical issue in several places. If it was sriving ok and running on boost But a bit rough you may have a partial tear in the line to the MAP sensor on the firewall. Trace it back to the throttle.


Check over loom plugs and earths too.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC + 10 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group