Are you being blocked from seeing Photobucket images in AusRotary posts?

Well, there is a temporary fix available in the form of a browser extension/plugin.

You can find them here:



We are working on a permanent solution that will mean all externally hosted images that are still online are hosted by us. In the meantime, try these to get the page working properly.

This announcement can be dismissed by clicking on the 'X' in the top right hand corner.

OIL TEMP AND SENSOR LOCATION

Any type of technical questions or info

Moderators: KillerRx4, orx626

Post Reply
Message
Author
rotor_speed
Rotary?... What The?
Posts: 31
Joined: Sat Aug 12, 2017 4:17 pm

OIL TEMP AND SENSOR LOCATION

#1 Post by rotor_speed » Mon Aug 14, 2017 3:20 am

at the moment I have a remote Derale usa made oil cooler with a second k&n large oil filter my 13b Bridgeport.
with the filter on the 13b location up the top near back of engine I have a oil temp sensor located,so when my saas brand guage reads the temp would that read before or after the oil cooler has done its job reducing the oil temp ?

once engine is warmed up it runs between 90-100 degrees is that ok ?
also I was using penrite hpr 30 20w60 weight oil but thinking of changing back to 20w50 oil,your thoughts please ?

any advice would be great thanks.



User avatar
bumpstart
Uber Post Whore
Posts: 11644
Joined: Mon Jun 05, 2006 11:43 pm
Location: uranus

Re: OIL TEMP AND SENSOR LOCATION

#2 Post by bumpstart » Mon Aug 14, 2017 5:27 pm

the temp is after the oil cooler ..temps are perfect .. 20W -60 is fine unless you live with snow


when the going is hard, don't retard, remember your lubrication
27 years of rotary DIY
tech forum is for tech questions.. private message box is for private messages
paypal : bumpstart13b@hotmail.com

rotor_speed
Rotary?... What The?
Posts: 31
Joined: Sat Aug 12, 2017 4:17 pm

Re: OIL TEMP AND SENSOR LOCATION

#3 Post by rotor_speed » Tue Aug 15, 2017 7:01 pm

thanks for the great info help bumpstart cheers :)



Post Reply